summaryrefslogtreecommitdiff
path: root/gemset.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gemset.nix')
-rw-r--r--gemset.nix92
1 files changed, 56 insertions, 36 deletions
diff --git a/gemset.nix b/gemset.nix
index bcd5519..cd4aba0 100644
--- a/gemset.nix
+++ b/gemset.nix
@@ -1,14 +1,14 @@
{
activesupport = {
- dependencies = ["multi_json"];
+ dependencies = ["concurrent-ruby" "i18n" "minitest" "tzinfo" "zeitwerk"];
groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0sviwqwbgd8yv7dkb9ja1pgn3kkmnzxys3w06k5lrbhbcpqhhvic";
+ sha256 = "1csxddyhl6k773ycxjvmyshyr4g9jb1icbs3pnm7crnavqs4h1yr";
type = "gem";
};
- version = "3.1.12";
+ version = "6.1.3.2";
};
addressable = {
dependencies = ["public_suffix"];
@@ -36,10 +36,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1vnxrbhi7cq3p4y2v9iwd10v1c7l15is4var14hwnb2jip4fyjzz";
+ sha256 = "0nwad3211p7yv9sda31jmbyw6sdafzmdi2i2niaz6f0wk5nq9h0f";
type = "gem";
};
- version = "1.1.7";
+ version = "1.1.9";
};
em-websocket = {
dependencies = ["eventmachine" "http_parser.rb"];
@@ -67,10 +67,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "12lpwaw82bb0rm9f52v1498bpba8aj2l2q359mkwbxsswhpga5af";
+ sha256 = "1wgvaclp4h9y8zkrgz8p2hqkrgr4j7kz0366mik0970w532cbmcq";
type = "gem";
};
- version = "1.13.1";
+ version = "1.15.3";
};
forwardable-extended = {
groups = ["default" "jekyll_plugins"];
@@ -119,10 +119,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "153sx77p16vawrs4qpkv7qlzf9v5fks4g7xqcj1dwk40i6g7rfzk";
+ sha256 = "0g2fnag935zn2ggm5cn6k4s4xvv53v2givj1j90szmvavlpya96a";
type = "gem";
};
- version = "1.8.5";
+ version = "1.8.10";
};
jekyll = {
dependencies = ["addressable" "colorator" "em-websocket" "i18n" "jekyll-sass-converter" "jekyll-watch" "kramdown" "kramdown-parser-gfm" "liquid" "mercenary" "pathutil" "rouge" "safe_yaml" "terminal-table"];
@@ -141,10 +141,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1mgc1ik2cq2g8g7z9ql2i6ydzy771m2i4qrd1q77x8cf2sprlb0z";
+ sha256 = "1zxqkrnix0xiw98531h5ga6h69jhzlx2jh9qhvcl67p8nq3sgza9";
type = "gem";
};
- version = "0.15.0";
+ version = "0.15.1";
};
jekyll-paginate = {
groups = ["default"];
@@ -162,10 +162,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1zzm6jyv6hrn5akrf67slksk3k292vkllbiry92pwkkg8amxmdw9";
+ sha256 = "1xlkhpkhxb09xcnldf5gg3mv8jzl83xqscwnkaxm0hgmzjf4p4dw";
type = "gem";
};
- version = "1.0.4";
+ version = "1.1.2";
};
jekyll-sass-converter = {
dependencies = ["sassc"];
@@ -228,10 +228,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1vmw752c26ny2jwl0npn0gbyqwgz4hdmlpxnsld9qi9xhk5b1qh7";
+ sha256 = "0jdbcjv4v7sj888bv3vc6d1dg4ackkh7ywlmn9ln2g9alk7kisar";
type = "gem";
};
- version = "2.3.0";
+ version = "2.3.1";
};
kramdown-parser-gfm = {
dependencies = ["kramdown"];
@@ -260,10 +260,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1w923wmdi3gyiky0asqdw5dnh3gcjs2xyn82ajvjfjwh6sn0clgi";
+ sha256 = "0h2v34xhi30w0d9gfzds2w6v89grq2gkpgvmdj9m8x1ld1845xnj";
type = "gem";
};
- version = "3.2.1";
+ version = "3.5.1";
};
mercenary = {
groups = ["default" "jekyll_plugins"];
@@ -280,31 +280,31 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "15zplpfw3knqifj9bpf604rb3wc1vhq6363pd6lvhayng8wql5vy";
+ sha256 = "1ad0mli9rc0f17zw4ibp24dbj1y39zkykijsjmnzl4gwpg5s0j6k";
type = "gem";
};
- version = "2.4.0";
+ version = "2.5.3";
};
- multi_json = {
+ minitest = {
groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0pb1g1y3dsiahavspyzkdy39j4q377009f6ix0bh1ag4nqw43l0z";
+ sha256 = "19z7wkhg59y8abginfrm2wzplz7py3va8fyngiigngqvsws6cwgl";
type = "gem";
};
- version = "1.15.0";
+ version = "5.14.4";
};
nokogiri = {
- dependencies = ["mini_portile2"];
+ dependencies = ["mini_portile2" "racc"];
groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0xmf60nj5kg9vaj5bysy308687sgmkasgx06vbbnf94p52ih7si2";
+ sha256 = "1vrn31385ix5k9b0yalnlzv360isv6dincbcvi8psllnwz4sjxj9";
type = "gem";
};
- version = "1.10.10";
+ version = "1.11.7";
};
pathutil = {
dependencies = ["forwardable-extended"];
@@ -327,15 +327,25 @@
};
version = "4.0.6";
};
+ racc = {
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "178k7r0xn689spviqzhvazzvxfq6fyjldxb3ywjbgipbfi4s8j1g";
+ type = "gem";
+ };
+ version = "1.5.2";
+ };
rb-fsevent = {
groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1k9bsj7ni0g2fd7scyyy1sk9dy2pg9akniahab0iznvjmhn54h87";
+ sha256 = "1qsx9c4jr11vr3a9s5j83avczx9qn9rjaf32gxpc2v451hvbc0is";
type = "gem";
};
- version = "0.10.4";
+ version = "0.11.0";
};
rb-inotify = {
dependencies = ["ffi"];
@@ -353,20 +363,20 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1mkvkcw9fhpaizrhca0pdgjcrbns48rlz4g6lavl5gjjq3rk2sq3";
+ sha256 = "08ximcyfjy94pm1rhcx04ny1vx2sk0x4y185gzn86yfsbzwkng53";
type = "gem";
};
- version = "3.2.4";
+ version = "3.2.5";
};
rouge = {
groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0z4sp0227dljiqcg7cki53qww31f22nl7msvnnqrgpwijgg9y80v";
+ sha256 = "0b4b300i3m4m4kw7w1n9wgxwy16zccnb7271miksyzd0wq5b9pm3";
type = "gem";
};
- version = "3.23.0";
+ version = "3.26.0";
};
safe_yaml = {
groups = ["default" "jekyll_plugins"];
@@ -406,10 +416,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0z97ymgw0fcnmg22gfba1z11h35z2c8p1ynrn862cf585g4afnbl";
+ sha256 = "10qp5x7f9hvlc0psv9gsfbxg4a7s0485wsbq1kljkxq94in91l4z";
type = "gem";
};
- version = "2.0.2";
+ version = "2.0.4";
};
tzinfo-data = {
dependencies = ["tzinfo"];
@@ -417,10 +427,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1kjywciambyhlkc8ijp3kkx4r24pi9zs7plmxw003mxr6mrhah1w";
+ sha256 = "0ik16lnsyr2739jzwl4r5sz8q639lqw8f9s68iszwhm2pcq8p4w2";
type = "gem";
};
- version = "1.2020.1";
+ version = "1.2021.1";
};
unicode-display_width = {
groups = ["default" "jekyll_plugins"];
@@ -432,4 +442,14 @@
};
version = "1.7.0";
};
-} \ No newline at end of file
+ zeitwerk = {
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1746czsjarixq0x05f7p3hpzi38ldg6wxnxxw74kbjzh1sdjgmpl";
+ type = "gem";
+ };
+ version = "2.4.2";
+ };
+}