summaryrefslogtreecommitdiff
path: root/gemset.nix
diff options
context:
space:
mode:
authorKarl Hallsby <karl@hallsby.com>2022-08-08 16:46:20 -0500
committerKarl Hallsby <karl@hallsby.com>2022-08-08 16:46:20 -0500
commitf3948093aa23b42d95cfeb8cd74a65c23acd81f3 (patch)
treeea88434901a0ee75d7a37a29e18aa8a999a26c0a /gemset.nix
parent56a046f2e20e0c63b33fdaa54564f49cce2dc684 (diff)
Update Ruby Gems
Diffstat (limited to 'gemset.nix')
-rw-r--r--gemset.nix208
1 files changed, 46 insertions, 162 deletions
diff --git a/gemset.nix b/gemset.nix
index b43eb1f..958f058 100644
--- a/gemset.nix
+++ b/gemset.nix
@@ -1,14 +1,14 @@
{
activesupport = {
- dependencies = ["concurrent-ruby" "i18n" "minitest" "tzinfo" "zeitwerk"];
- groups = ["default" "jekyll_plugins"];
+ dependencies = ["concurrent-ruby" "i18n" "minitest" "tzinfo"];
+ groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "19gx1jcq46x9d1pi1w8xq0bgvvfw239y4lalr8asm291gj3q3ds4";
+ sha256 = "15lbq28v48i6q118p02m5zs9c63y1kv2h5krb3ss6q2vyaxhnfz7";
type = "gem";
};
- version = "6.1.4.1";
+ version = "7.0.3.1";
};
addressable = {
dependencies = ["public_suffix"];
@@ -21,39 +21,6 @@
};
version = "2.8.0";
};
- bibtex-ruby = {
- dependencies = ["latex-decode"];
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "0vynqa8q9hwghw6sdljr304b5gh11nqzy5nwqqwxmgy7pqyf7qw5";
- type = "gem";
- };
- version = "6.0.0";
- };
- citeproc = {
- dependencies = ["namae"];
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "13vl5sjmksk5a8kjcqnjxh7kn9gn1n4f9p1rvqfgsfhs54p0m6l2";
- type = "gem";
- };
- version = "1.0.10";
- };
- citeproc-ruby = {
- dependencies = ["citeproc" "csl"];
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "0a8ahyhhmdinl4kcyv51r74ipnclmfyz4zjv366dns8v49n5vkk3";
- type = "gem";
- };
- version = "1.1.14";
- };
colorator = {
groups = ["default" "jekyll_plugins"];
platforms = [];
@@ -69,32 +36,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0nwad3211p7yv9sda31jmbyw6sdafzmdi2i2niaz6f0wk5nq9h0f";
+ sha256 = "0s4fpn3mqiizpmpy2a24k4v365pv75y50292r8ajrv4i1p5b2k14";
type = "gem";
};
- version = "1.1.9";
- };
- csl = {
- dependencies = ["namae" "rexml"];
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "0n8iqmzvvqy2b1wfr4c7yj28x4z3zgm36628y8ybl49dgnmjycrk";
- type = "gem";
- };
- version = "1.6.0";
- };
- csl-styles = {
- dependencies = ["csl"];
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "0l29qlk7i74088fpba5iqhhgiqkj7glcmc42nbmvgqysx577nag8";
- type = "gem";
- };
- version = "1.0.1.11";
+ version = "1.1.10";
};
em-websocket = {
dependencies = ["eventmachine" "http_parser.rb"];
@@ -213,10 +158,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0ssxcywmb3flxsjdg13is6k01807zgzasdhj4j48dm7ac59cmksn";
+ sha256 = "1862ydmclzy1a0cjbvm8dz7847d9rch495ib0zb64y84d3xd4bkg";
type = "gem";
};
- version = "1.15.4";
+ version = "1.15.5";
};
forwardable-extended = {
groups = ["default" "jekyll_plugins"];
@@ -244,10 +189,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "080sn9z1a64gv04p318jz10y6lv6qd3avip08rrcmq9k4ihai0f1";
+ sha256 = "0w14wk9j375dcvh7cr833jqqsd8974x51ds30m26cr1pwxy8xgbh";
type = "gem";
};
- version = "2.14.0";
+ version = "2.14.2";
};
"http_parser.rb" = {
groups = ["default" "jekyll_plugins"];
@@ -265,10 +210,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0vdd1kii40qhbr9n8qx71k2gskq6rkl8ygy8hw5hfj8bb5a364xf";
+ sha256 = "1vdcchz7jli1p0gnc669a7bj3q1fv09y9ppf0y3k0vb1jwdwrqwi";
type = "gem";
};
- version = "1.8.11";
+ version = "1.12.0";
};
jekyll = {
dependencies = ["addressable" "colorator" "em-websocket" "i18n" "jekyll-sass-converter" "jekyll-watch" "kramdown" "kramdown-parser-gfm" "liquid" "mercenary" "pathutil" "rouge" "safe_yaml" "terminal-table"];
@@ -297,10 +242,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1zxqkrnix0xiw98531h5ga6h69jhzlx2jh9qhvcl67p8nq3sgza9";
+ sha256 = "0b4pgfi1bdn458j2a6rx02ps75pfrz6876p1pr1g35z6z7pc9bjl";
type = "gem";
};
- version = "0.15.1";
+ version = "0.16.0";
};
jekyll-github-metadata = {
dependencies = ["jekyll" "octokit"];
@@ -341,10 +286,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "04ncr44wrilz26ayqwlg7379yjnkb29mvx4j04i62b7czmdrc9dv";
+ sha256 = "077xkkkb592vg8kxdia9jwsaz1bc70lkpf4hdvazjqphn5hlz2bi";
type = "gem";
};
- version = "2.1.0";
+ version = "2.2.0";
};
jekyll-scholar = {
dependencies = ["bibtex-ruby" "citeproc-ruby" "csl-styles" "jekyll"];
@@ -406,10 +351,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0jdbcjv4v7sj888bv3vc6d1dg4ackkh7ywlmn9ln2g9alk7kisar";
+ sha256 = "1ic14hdcqxn821dvzki99zhmcy130yhv5fqfffkcf87asv5mnbmn";
type = "gem";
};
- version = "2.3.1";
+ version = "2.4.0";
};
kramdown-parser-gfm = {
dependencies = ["kramdown"];
@@ -448,10 +393,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0ncfhdkjiwq9l1pm87ax2pa20kz2j0dz56vi74cnr5a6cfk0qb5p";
+ sha256 = "0agybr37wpjv3xy4ipcmsvsibgdgphzrwbvcj4vfiykpmakwm01v";
type = "gem";
};
- version = "3.7.0";
+ version = "3.7.1";
};
mercenary = {
groups = ["default" "jekyll_plugins"];
@@ -468,83 +413,62 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1lvxm91hi0pabnkkg47wh1siv56s6slm2mdq1idfm86dyfidfprq";
+ sha256 = "0rapl1sfmfi3bfr68da4ca16yhc0pp93vjwkj7y3rdqrzy3b41hy";
type = "gem";
};
- version = "2.6.1";
+ version = "2.8.0";
};
minitest = {
groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "19z7wkhg59y8abginfrm2wzplz7py3va8fyngiigngqvsws6cwgl";
- type = "gem";
- };
- version = "5.14.4";
- };
- multipart-post = {
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "1zgw9zlwh2a6i1yvhhc4a84ry1hv824d6g2iw2chs3k5aylpmpfj";
+ sha256 = "14a9ign0hj3z3j4cpfplj2djaskx3skzyx4fl3x53d7saxmhrgn1";
type = "gem";
};
- version = "2.1.1";
- };
- namae = {
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "1j3nl1klkx3gymrdxfc1hlq4a8qlvhhl9aj5v1v08b9fz27sky0l";
- type = "gem";
- };
- version = "1.1.1";
+ version = "5.16.2";
};
nokogiri = {
dependencies = ["mini_portile2" "racc"];
- groups = ["default" "jekyll_plugins"];
+ groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1v02g7k7cxiwdcahvlxrmizn3avj2q6nsjccgilq1idc89cr081b";
+ sha256 = "0g7axlq2y6gzmixzzzhw3fn6nhrhg469jj8gfr7gs8igiclpkhkr";
type = "gem";
};
- version = "1.12.5";
+ version = "1.13.8";
};
- octokit = {
- dependencies = ["faraday" "sawyer"];
+ pathutil = {
+ dependencies = ["forwardable-extended"];
groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0ak64rb48d8z98nw6q70r6i0i3ivv61iqla40ss5l79491qfnn27";
+ sha256 = "12fm93ljw9fbxmv2krki5k5wkvr7560qy8p4spvb9jiiaqv78fz4";
type = "gem";
};
- version = "4.21.0";
+ version = "0.16.2";
};
- pathutil = {
- dependencies = ["forwardable-extended"];
+ public_suffix = {
groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "12fm93ljw9fbxmv2krki5k5wkvr7560qy8p4spvb9jiiaqv78fz4";
+ sha256 = "1f3knlwfwm05sfbaihrxm4g772b79032q14c16q4b38z8bi63qcb";
type = "gem";
};
- version = "0.16.2";
+ version = "4.0.7";
};
- public_suffix = {
- groups = ["default" "jekyll_plugins"];
+ racc = {
+ groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1xqcgkl7bwws1qrlnmxgh8g4g9m10vg60bhlw40fplninb3ng6d9";
+ sha256 = "0la56m0z26j3mfn1a9lf2l03qx1xifanndf9p3vx1azf6sqy7v9d";
type = "gem";
};
- version = "4.0.6";
+ version = "1.6.0";
};
racc = {
groups = ["default" "jekyll_plugins"];
@@ -561,10 +485,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1qsx9c4jr11vr3a9s5j83avczx9qn9rjaf32gxpc2v451hvbc0is";
+ sha256 = "06c50pvxib7wqnv6q0f3n7gzfcrp5chi3sa48hxpkfxc3hhy11fm";
type = "gem";
};
- version = "0.11.0";
+ version = "0.11.1";
};
rb-inotify = {
dependencies = ["ffi"];
@@ -592,20 +516,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "197k0vskf72wxx0gzwld2jzg27bb7982xlvnzy9adlvkzp7nh8vf";
- type = "gem";
- };
- version = "3.26.1";
- };
- ruby2_keywords = {
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "1vz322p8n39hz3b4a9gkmz9y7a5jaz41zrm2ywf31dvkqm03glgz";
+ sha256 = "1dnfkrk8xx2m8r3r9m2p5xcq57viznyc09k7r3i4jbm758i57lx3";
type = "gem";
};
- version = "0.0.5";
+ version = "3.30.0";
};
safe_yaml = {
groups = ["default" "jekyll_plugins"];
@@ -656,10 +570,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "10qp5x7f9hvlc0psv9gsfbxg4a7s0485wsbq1kljkxq94in91l4z";
+ sha256 = "0rx114mpqnw2k4h98vc0rs0x0bmf0img84yh8mkkjkal07cjydf5";
type = "gem";
};
- version = "2.0.4";
+ version = "2.0.5";
};
tzinfo-data = {
dependencies = ["tzinfo"];
@@ -667,10 +581,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0w1iyvw0m2xvdr4654jnn1g27jwj84y94dvaj1k2p3lcrvndm698";
+ sha256 = "0yvfyxz70r45j65763fzy0p5j8cxlhnpn1n5lcxj4is7hp8v5i23";
type = "gem";
};
- version = "1.2021.5";
+ version = "1.2022.1";
};
unicode-display_width = {
groups = ["default" "jekyll_plugins"];
@@ -682,34 +596,4 @@
};
version = "1.8.0";
};
- unicode_utils = {
- groups = ["jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "0h1a5yvrxzlf0lxxa1ya31jcizslf774arnsd89vgdhk4g7x08mr";
- type = "gem";
- };
- version = "1.4.0";
- };
- webrick = {
- groups = ["jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "1d4cvgmxhfczxiq5fr534lmizkhigd15bsx5719r5ds7k7ivisc7";
- type = "gem";
- };
- version = "1.7.0";
- };
- zeitwerk = {
- groups = ["default" "jekyll_plugins"];
- platforms = [];
- source = {
- remotes = ["https://rubygems.org"];
- sha256 = "18l4r6layck0d80ydc692mv1lxak5xbf6w2paj1x7m2ggbggzxgj";
- type = "gem";
- };
- version = "2.5.1";
- };
}