summaryrefslogtreecommitdiff
path: root/gemset.nix
diff options
context:
space:
mode:
authorKarl Hallsby <karl@hallsby.com>2021-10-03 00:35:46 -0500
committerKarl Hallsby <karl@hallsby.com>2021-10-03 02:16:55 -0500
commite2c06d2681e18946ab6c3e3e6075aed92a4d13be (patch)
treeb30dce94387f4717394277932f691519e0281c44 /gemset.nix
parenta10ad0a99ba6e44a35253c3bcaff80c90e99348e (diff)
Change to al-folio theme
Theme at: https://github.com/alshedivat/al-folio
Diffstat (limited to 'gemset.nix')
-rw-r--r--gemset.nix321
1 files changed, 301 insertions, 20 deletions
diff --git a/gemset.nix b/gemset.nix
index cd4aba0..ee95957 100644
--- a/gemset.nix
+++ b/gemset.nix
@@ -1,14 +1,14 @@
{
activesupport = {
dependencies = ["concurrent-ruby" "i18n" "minitest" "tzinfo" "zeitwerk"];
- groups = ["default"];
+ groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1csxddyhl6k773ycxjvmyshyr4g9jb1icbs3pnm7crnavqs4h1yr";
+ sha256 = "19gx1jcq46x9d1pi1w8xq0bgvvfw239y4lalr8asm291gj3q3ds4";
type = "gem";
};
- version = "6.1.3.2";
+ version = "6.1.4.1";
};
addressable = {
dependencies = ["public_suffix"];
@@ -16,10 +16,43 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1fvchp2rhp2rmigx7qglf69xvjqvzq7x0g49naliw29r2bz656sy";
+ sha256 = "022r3m9wdxljpbya69y2i3h9g3dhhfaqzidf95m6qjzms792jvgp";
+ type = "gem";
+ };
+ version = "2.8.0";
+ };
+ bibtex-ruby = {
+ dependencies = ["latex-decode"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0vynqa8q9hwghw6sdljr304b5gh11nqzy5nwqqwxmgy7pqyf7qw5";
+ type = "gem";
+ };
+ version = "6.0.0";
+ };
+ citeproc = {
+ dependencies = ["namae"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "13vl5sjmksk5a8kjcqnjxh7kn9gn1n4f9p1rvqfgsfhs54p0m6l2";
type = "gem";
};
- version = "2.7.0";
+ version = "1.0.10";
+ };
+ citeproc-ruby = {
+ dependencies = ["citeproc" "csl"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0a8ahyhhmdinl4kcyv51r74ipnclmfyz4zjv366dns8v49n5vkk3";
+ type = "gem";
+ };
+ version = "1.1.14";
};
colorator = {
groups = ["default" "jekyll_plugins"];
@@ -41,6 +74,28 @@
};
version = "1.1.9";
};
+ csl = {
+ dependencies = ["namae" "rexml"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0n8iqmzvvqy2b1wfr4c7yj28x4z3zgm36628y8ybl49dgnmjycrk";
+ type = "gem";
+ };
+ version = "1.6.0";
+ };
+ csl-styles = {
+ dependencies = ["csl"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0l29qlk7i74088fpba5iqhhgiqkj7glcmc42nbmvgqysx577nag8";
+ type = "gem";
+ };
+ version = "1.0.1.11";
+ };
em-websocket = {
dependencies = ["eventmachine" "http_parser.rb"];
groups = ["default" "jekyll_plugins"];
@@ -62,15 +117,106 @@
};
version = "1.2.7";
};
+ faraday = {
+ dependencies = ["faraday-em_http" "faraday-em_synchrony" "faraday-excon" "faraday-httpclient" "faraday-net_http" "faraday-net_http_persistent" "faraday-patron" "faraday-rack" "multipart-post" "ruby2_keywords"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0afhlqgby2cizcwgh7h2sq5f77q01axjbdl25bsvfwsry9n7gyyi";
+ type = "gem";
+ };
+ version = "1.8.0";
+ };
+ faraday-em_http = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "12cnqpbak4vhikrh2cdn94assh3yxza8rq2p9w2j34bqg5q4qgbs";
+ type = "gem";
+ };
+ version = "1.0.0";
+ };
+ faraday-em_synchrony = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1vgrbhkp83sngv6k4mii9f2s9v5lmp693hylfxp2ssfc60fas3a6";
+ type = "gem";
+ };
+ version = "1.0.0";
+ };
+ faraday-excon = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0h09wkb0k0bhm6dqsd47ac601qiaah8qdzjh8gvxfd376x1chmdh";
+ type = "gem";
+ };
+ version = "1.1.0";
+ };
+ faraday-httpclient = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0fyk0jd3ks7fdn8nv3spnwjpzx2lmxmg2gh4inz3by1zjzqg33sc";
+ type = "gem";
+ };
+ version = "1.0.1";
+ };
+ faraday-net_http = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1fi8sda5hc54v1w3mqfl5yz09nhx35kglyx72w7b8xxvdr0cwi9j";
+ type = "gem";
+ };
+ version = "1.0.1";
+ };
+ faraday-net_http_persistent = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0dc36ih95qw3rlccffcb0vgxjhmipsvxhn6cw71l7ffs0f7vq30b";
+ type = "gem";
+ };
+ version = "1.2.0";
+ };
+ faraday-patron = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "19wgsgfq0xkski1g7m96snv39la3zxz6x7nbdgiwhg5v82rxfb6w";
+ type = "gem";
+ };
+ version = "1.0.0";
+ };
+ faraday-rack = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1h184g4vqql5jv9s9im6igy00jp6mrah2h14py6mpf9bkabfqq7g";
+ type = "gem";
+ };
+ version = "1.0.0";
+ };
ffi = {
groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1wgvaclp4h9y8zkrgz8p2hqkrgr4j7kz0366mik0970w532cbmcq";
+ sha256 = "0ssxcywmb3flxsjdg13is6k01807zgzasdhj4j48dm7ac59cmksn";
type = "gem";
};
- version = "1.15.3";
+ version = "1.15.4";
};
forwardable-extended = {
groups = ["default" "jekyll_plugins"];
@@ -135,6 +281,16 @@
};
version = "4.1.1";
};
+ jekyll-email-protect = {
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "13ccalan5shkj8j4i7x3lpq7zap02gwqw63i7yp8h1vikj9j1mh0";
+ type = "gem";
+ };
+ version = "1.1.0";
+ };
jekyll-feed = {
dependencies = ["jekyll"];
groups = ["jekyll_plugins"];
@@ -146,6 +302,17 @@
};
version = "0.15.1";
};
+ jekyll-github-metadata = {
+ dependencies = ["jekyll" "octokit"];
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0r4m7r4qyd3pqkp5xlyp3zzy47i18kjgwq995nrspysgkmc4qmw1";
+ type = "gem";
+ };
+ version = "2.13.0";
+ };
jekyll-paginate = {
groups = ["default"];
platforms = [];
@@ -156,6 +323,17 @@
};
version = "1.1.0";
};
+ jekyll-paginate-v2 = {
+ dependencies = ["jekyll"];
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1qzlqhpiqz28624fp0ak76hfy7908w6kpx62v7z43aiwjv0yc6q0";
+ type = "gem";
+ };
+ version = "3.0.0";
+ };
jekyll-pdf-embed = {
dependencies = ["jekyll"];
groups = ["jekyll_plugins"];
@@ -178,6 +356,17 @@
};
version = "2.1.0";
};
+ jekyll-scholar = {
+ dependencies = ["bibtex-ruby" "citeproc-ruby" "csl-styles" "jekyll"];
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1iig7jmng8lw81anvcbnjq76n7kn4d9dmqjh0jq9j0in3vbprzjb";
+ type = "gem";
+ };
+ version = "7.0.0";
+ };
jekyll-sitemap = {
dependencies = ["jekyll"];
groups = ["default"];
@@ -200,6 +389,16 @@
};
version = "2.2.6";
};
+ jekyll-twitter-plugin = {
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1kbsi24z6z5mibw6rkvx2mp23h5122hxjqrixkf48lkh2dlfhpnj";
+ type = "gem";
+ };
+ version = "2.1.0";
+ };
jekyll-watch = {
dependencies = ["listen"];
groups = ["default" "jekyll_plugins"];
@@ -244,6 +443,16 @@
};
version = "1.1.0";
};
+ latex-decode = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1wnxg82lfkb8bl5la9nmg1434rpkcygygm0ckixjn6ah2dy6i53m";
+ type = "gem";
+ };
+ version = "0.3.2";
+ };
liquid = {
groups = ["default" "jekyll_plugins"];
platforms = [];
@@ -260,10 +469,10 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0h2v34xhi30w0d9gfzds2w6v89grq2gkpgvmdj9m8x1ld1845xnj";
+ sha256 = "0ncfhdkjiwq9l1pm87ax2pa20kz2j0dz56vi74cnr5a6cfk0qb5p";
type = "gem";
};
- version = "3.5.1";
+ version = "3.7.0";
};
mercenary = {
groups = ["default" "jekyll_plugins"];
@@ -276,14 +485,14 @@
version = "0.4.0";
};
mini_portile2 = {
- groups = ["default"];
+ groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1ad0mli9rc0f17zw4ibp24dbj1y39zkykijsjmnzl4gwpg5s0j6k";
+ sha256 = "1lvxm91hi0pabnkkg47wh1siv56s6slm2mdq1idfm86dyfidfprq";
type = "gem";
};
- version = "2.5.3";
+ version = "2.6.1";
};
minitest = {
groups = ["default"];
@@ -295,16 +504,47 @@
};
version = "5.14.4";
};
+ multipart-post = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1zgw9zlwh2a6i1yvhhc4a84ry1hv824d6g2iw2chs3k5aylpmpfj";
+ type = "gem";
+ };
+ version = "2.1.1";
+ };
+ namae = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1j3nl1klkx3gymrdxfc1hlq4a8qlvhhl9aj5v1v08b9fz27sky0l";
+ type = "gem";
+ };
+ version = "1.1.1";
+ };
nokogiri = {
dependencies = ["mini_portile2" "racc"];
- groups = ["default"];
+ groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1vrn31385ix5k9b0yalnlzv360isv6dincbcvi8psllnwz4sjxj9";
+ sha256 = "1v02g7k7cxiwdcahvlxrmizn3avj2q6nsjccgilq1idc89cr081b";
type = "gem";
};
- version = "1.11.7";
+ version = "1.12.5";
+ };
+ octokit = {
+ dependencies = ["faraday" "sawyer"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0ak64rb48d8z98nw6q70r6i0i3ivv61iqla40ss5l79491qfnn27";
+ type = "gem";
+ };
+ version = "4.21.0";
};
pathutil = {
dependencies = ["forwardable-extended"];
@@ -373,10 +613,20 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0b4b300i3m4m4kw7w1n9wgxwy16zccnb7271miksyzd0wq5b9pm3";
+ sha256 = "197k0vskf72wxx0gzwld2jzg27bb7982xlvnzy9adlvkzp7nh8vf";
+ type = "gem";
+ };
+ version = "3.26.1";
+ };
+ ruby2_keywords = {
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1vz322p8n39hz3b4a9gkmz9y7a5jaz41zrm2ywf31dvkqm03glgz";
type = "gem";
};
- version = "3.26.0";
+ version = "0.0.5";
};
safe_yaml = {
groups = ["default" "jekyll_plugins"];
@@ -399,6 +649,17 @@
};
version = "2.4.0";
};
+ sawyer = {
+ dependencies = ["addressable" "faraday"];
+ groups = ["default" "jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0yrdchs3psh583rjapkv33mljdivggqn99wkydkjdckcjn43j3cz";
+ type = "gem";
+ };
+ version = "0.8.2";
+ };
terminal-table = {
dependencies = ["unicode-display_width"];
groups = ["default" "jekyll_plugins"];
@@ -427,17 +688,37 @@
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "0ik16lnsyr2739jzwl4r5sz8q639lqw8f9s68iszwhm2pcq8p4w2";
+ sha256 = "1f9wlg8p1p1wa86hcskiy58abbdysdqwr4pv2dmkhkfbi94f1lmr";
type = "gem";
};
- version = "1.2021.1";
+ version = "1.2021.3";
};
unicode-display_width = {
groups = ["default" "jekyll_plugins"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "06i3id27s60141x6fdnjn5rar1cywdwy64ilc59cz937303q3mna";
+ sha256 = "1204c1jx2g89pc25qk5150mk7j5k90692i7ihgfzqnad6qni74h2";
+ type = "gem";
+ };
+ version = "1.8.0";
+ };
+ unicode_utils = {
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0h1a5yvrxzlf0lxxa1ya31jcizslf774arnsd89vgdhk4g7x08mr";
+ type = "gem";
+ };
+ version = "1.4.0";
+ };
+ webrick = {
+ groups = ["jekyll_plugins"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1d4cvgmxhfczxiq5fr534lmizkhigd15bsx5719r5ds7k7ivisc7";
type = "gem";
};
version = "1.7.0";