summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorKarl Hallsby <karl@hallsby.com>2020-07-08 00:30:29 +0200
committerKarl Hallsby <karl@hallsby.com>2020-07-08 00:30:29 +0200
commit1218f568ff79aaf1fcbfccd46d99b92b213a8745 (patch)
tree0146bb78cd7983a99fd91f1443ada0dac7479725 /default.nix
parente68c292946d564d97992de11531af6121c488234 (diff)
Create nix-shell environment for development computers
I used the bundix program to generate the gemset.nix file. You can generate the same thing with `nix-env -iA bundix`. I then quickly wrote a default.nix so that I can open a nix-shell in the project directory, to make my life much, much easier to develop with Nix and others. I am keeping the other gemfiles for now, because I am developing over several different systems and might need to keep it for now.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..5998dda
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,12 @@
+with (import <nixpkgs> {});
+let
+ gems = bundlerEnv {
+ name = "Personal_Website";
+ inherit ruby;
+ gemdir = ./.;
+ };
+
+in stdenv.mkDerivation {
+ name = "Personal_Website";
+ buildInputs = [ gems ruby ];
+}