summaryrefslogtreecommitdiff
path: root/gemset.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gemset.nix')
-rw-r--r--gemset.nix120
1 files changed, 113 insertions, 7 deletions
diff --git a/gemset.nix b/gemset.nix
index 2276084..bcd5519 100644
--- a/gemset.nix
+++ b/gemset.nix
@@ -1,4 +1,15 @@
{
+ activesupport = {
+ dependencies = ["multi_json"];
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0sviwqwbgd8yv7dkb9ja1pgn3kkmnzxys3w06k5lrbhbcpqhhvic";
+ type = "gem";
+ };
+ version = "3.1.12";
+ };
addressable = {
dependencies = ["public_suffix"];
groups = ["default" "jekyll_plugins"];
@@ -71,6 +82,27 @@
};
version = "2.6.0";
};
+ gemoji = {
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0vgklpmhdz98xayln5hhqv4ffdyrglzwdixkn5gsk9rj94pkymc0";
+ type = "gem";
+ };
+ version = "3.0.1";
+ };
+ html-pipeline = {
+ dependencies = ["activesupport" "nokogiri"];
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "080sn9z1a64gv04p318jz10y6lv6qd3avip08rrcmq9k4ihai0f1";
+ type = "gem";
+ };
+ version = "2.14.0";
+ };
"http_parser.rb" = {
groups = ["default" "jekyll_plugins"];
platforms = [];
@@ -114,6 +146,16 @@
};
version = "0.15.0";
};
+ jekyll-paginate = {
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0r7bcs8fq98zldih4787zk5i9w24nz5wa26m84ssja95n3sas2l8";
+ type = "gem";
+ };
+ version = "1.1.0";
+ };
jekyll-pdf-embed = {
dependencies = ["jekyll"];
groups = ["jekyll_plugins"];
@@ -136,16 +178,27 @@
};
version = "2.1.0";
};
- jekyll-seo-tag = {
+ jekyll-sitemap = {
dependencies = ["jekyll"];
groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1p9fl2r4ni10lbx143zp41caldjs4hg27az5wg42sbwzb7s6z66m";
+ sha256 = "0622rwsn5i0m5xcyzdn86l68wgydqwji03lqixdfm1f1xdfqrq0d";
type = "gem";
};
- version = "2.6.1";
+ version = "1.4.0";
+ };
+ jekyll-text-theme = {
+ dependencies = ["jekyll" "jekyll-feed" "jekyll-paginate" "jekyll-sitemap" "jemoji"];
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0agc5mls60imbamwcxrnm73iadq178nqdziyplmdxkvalrc5rfwc";
+ type = "gem";
+ };
+ version = "2.2.6";
};
jekyll-watch = {
dependencies = ["listen"];
@@ -158,6 +211,17 @@
};
version = "2.2.1";
};
+ jemoji = {
+ dependencies = ["gemoji" "html-pipeline" "jekyll"];
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "09sxbnrqz5vf6rxmh6lzism31gz2g3hw86ymg37r1ccknclv3cp9";
+ type = "gem";
+ };
+ version = "0.12.0";
+ };
kramdown = {
dependencies = ["rexml"];
groups = ["default" "jekyll_plugins"];
@@ -211,16 +275,36 @@
};
version = "0.4.0";
};
- minima = {
- dependencies = ["jekyll" "jekyll-feed" "jekyll-seo-tag"];
+ mini_portile2 = {
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "15zplpfw3knqifj9bpf604rb3wc1vhq6363pd6lvhayng8wql5vy";
+ type = "gem";
+ };
+ version = "2.4.0";
+ };
+ multi_json = {
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0pb1g1y3dsiahavspyzkdy39j4q377009f6ix0bh1ag4nqw43l0z";
+ type = "gem";
+ };
+ version = "1.15.0";
+ };
+ nokogiri = {
+ dependencies = ["mini_portile2"];
groups = ["default"];
platforms = [];
source = {
remotes = ["https://rubygems.org"];
- sha256 = "1gk7jmriiswda1ykjzpsw9cpiya4m9n0yrh0h6xnrc8zcfy543jj";
+ sha256 = "0xmf60nj5kg9vaj5bysy308687sgmkasgx06vbbnf94p52ih7si2";
type = "gem";
};
- version = "2.5.1";
+ version = "1.10.10";
};
pathutil = {
dependencies = ["forwardable-extended"];
@@ -316,6 +400,28 @@
};
version = "1.8.0";
};
+ tzinfo = {
+ dependencies = ["concurrent-ruby"];
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "0z97ymgw0fcnmg22gfba1z11h35z2c8p1ynrn862cf585g4afnbl";
+ type = "gem";
+ };
+ version = "2.0.2";
+ };
+ tzinfo-data = {
+ dependencies = ["tzinfo"];
+ groups = ["default"];
+ platforms = [];
+ source = {
+ remotes = ["https://rubygems.org"];
+ sha256 = "1kjywciambyhlkc8ijp3kkx4r24pi9zs7plmxw003mxr6mrhah1w";
+ type = "gem";
+ };
+ version = "1.2020.1";
+ };
unicode-display_width = {
groups = ["default" "jekyll_plugins"];
platforms = [];